CustomerFirst Java Edition requires that Java Runtime 1.4.2 or above be installed on your machine.  If you do not see the Launch CustomerFirst link above, you should Click here to download and install Java Runtime 5.0 first and then Launch CustomerFirst.

When you see the prompt for Create Shortcut, or Desktop Integration if you are using Java 1.4.2,  you should choose Yes so that Desktop shortcut and Startup menu will be added.  Later, you can use the shortcut or menu to launch the application without using a browser.  Whenever there is a new version of the application available on the server, it will be automatically downloaded by the Java Runtime.